SketchUp Basic Tutorial

From Blue Mars Developer Guidebook

Jump to: navigation, search


Contents

Installation and Setup

Download SketchUp: Get Version 7.0.10247 from HileHippo Download Page or get software and manual from Blue Mars Builders Kit 0.75 Pt 2

NOTE: The latest version (7.1) does not export materials properly

Set Template: Use Window Menu > Preferences > Template tab > one of the metric templates such as Product Design and Woodworking, Millimeters

Set Units: Use Window Menu > Model Info > Units tab > Length Units = Decimal Centimeters Blue Mars uses centimeters for individual objects, and meters for city and block locations.

Create Object

Create Shape:

Do not leave unattached vertexes or lines. For a simple example with a box use the Toolbar > Rectangle icon (3rd button), and left-mouse-drag in the perspective area to make a rectangle. Then use Toolbar > Push/Pull icon (10th button), and left-mouse-drag on the rectangle you made to turn it into a box.
Position relative to the zero point of the axes will be preserved. So if you want your object to be centered, build it at the axis origin.

Add Custom Materials:

Navigate to Program Files\Google\Google Sketchup 7\Materials and add a folder or folders for your custom textures.
Edit your textures to a power-of-two width and height (128, 256, 512 etc pixels) and put them in the folders you made.
Use Toolbar > Paint Bucket (9th button) to open Materials floating window. Click second button on the right side Create Material. Choose a name for it, and then check Texture > Use texture image. To the right of the file name box, click the Choose Image button and select your texture. Then click OK button.
Use Materials window > Display the Secondary Selection Pane button and then choose the Select tab. In the lower Select Pane choose your custom folder from the dropdown list. Drag you new material from the upper to lower pane, and in the future the select pane will show your textures in your custom folder.

Texture Sides:

Do Not Leave Unpainted Faces. With the Materials window open, click faces of the box you made with the mouse (paint bucket).

Save Object:

Use File > Export > 3D Model and save as Google Earth (.kmz). Use a filename with no spaces. You can use underscores ( _ ) for readability: "My_Box.kmz". Close SketchUp.

Extract and Convert Files

If you do not already have it, install the 7zip file compression program.
Use 7zip to unpack the My_Box.kmz (kmz is actually a 7zip archive)
Create a new folder under Blue Mars City Developer Tools\Game\Objects\MyData. You can organize sub-folders below MyData how you like, but use a separate folder for each object you create.
From the unpacked .kmz folder, under models, copy the My_Box.dae to your new folder under MyData.
Use an image editing program such as Photoshop with the Nvidia texture tools plugin to convert your textures to .dds format and place them in the folder with the model file.

Use Item Editor to Import

Run the Blue Mars Item Editor > File > Open and select your My_Box.dae.
In the COLLADA Converter Tool window, choose Convert > Overwrite > Load. The object will be invisible at this point, with an outline showing. Two new files will be created: A CryTek Geometry file (.cgf) and a Material Settings file (.mtl). The latter is in XML format and can be edited directly with a text editor, but the Material Editor window will show changes immediately.
Use View Menu > Open View Pane > Material Editor to open that window.
In the left pane, find objects\mydata\...\My_Box and click the [+] to display the sub-materials. "bmImportProxy" is a sub-material for the collision boundary proxy for your object. The other submaterials are for the textures you used.
Click one of the submaterials to show it's detailed settings in the right pane. The opacity/transparency scale is reversed in SketchUp vs Blue Mars, so in the right pane use Opacity Settings > Opacity > 100 with the number box or slider to make the texture visible. Repeat for all textures. Your box should now be visible, assuming you kept the same texture file names as was used in Sketchup. If not, use the Texture Maps > Diffuse > folder button to point to your dds textures.
Adjust UV Modifier and other settings in the Material editor to what you want. See the Material Editor page for details.
Material settings changes are immediately saved into the .mtl file, so no File > Save is necessary, just exit the program when done.
Problems with this wiki page? Contact us either by: Support Email or Support Ticket System

Blue Mars Guidebook Privacy Policy
Blue Mars Guidebook Community Guidelines

Personal tools